'travis lint' still doesn't support matrix: include: in .travis.yml

travis lint

Warnings for .travis.yml:

in matrix.allow_failures section: specified python, but setting is not relevant for ruby

in matrix.include section: unexpected key language, dropping

in matrix.include section: specified python, but setting is not relevant for ruby

in matrix.include section: unexpected key dist, dropping

missing key language, defaulting to ruby

specified python, but setting is not relevant for ruby

.travis.yml is here:

Unfortunately, our linting tool is out of date and clearly needs some love.

I can’t promise any ETA but we have something in the work that will give lint warning right in our web UI.

Please keep an eye on our changelog to know when it’s out.

Thank you for your understanding!

Imprint