Travis Focal ubuntu image uses now expired mongodb 4.4 package

It seems that your 20.04 focal ubuntu image uses now expired mongodb 4.4 package:

W: GPG error: MongoDB Repositories focal/mongodb-org/4.4 Release: The following signatures were invalid: EXPKEYSIG 656408E390CFB1F5 MongoDB 4.4 Release Signing Key

E: The repository ‘MongoDB Repositories focal/mongodb-org/4.4 Release’ is not signed.


To be clear, this would appear (to me, at least) to impact all users of Focal on Travis: you don’t have to want Mongo, you will hit the issue with a simple “apt-get update”…


In my case, the build is failing during a libreoffice package addition.
To fix it, I added this line before the libreoffice package.
sudo curl -fsSL | sudo apt-key add -

Hi @mattihelminen,

Try this as a fix:

dist: focal
language: minimal

  - wget -qO - | sudo apt-key add -
  - echo "deb [ arch=amd64,arm64 ] focal/mongodb-org/4.4 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-4.4.list
  - sudo apt-get update
  - sudo apt-get install -y mongodb-org

  - mongodb

The rest of your .travis.yml here.

Let me know if this works, I’ll look into this internally and see if we can have it fetch the right version.

Thanks @Montana, that did the trick! Now our builds are once again working. If you can look in to fetching the right version for focal that would be sweet as well.

Having to update travis configurations to work around a problem that should be solved in the Travis infrastructure is suboptimal.

Hi @DBugger32,

Even though my hot fix worked - we are deploying a Focal image with the newest version of MongoDB tomorrow.