Travis failing to pull from IBM Cloud CLI Tools download site - ssl error

Within my build I pull down the IBM Cloud CLI tools, so that I can login to my IBM cloud account and push my built docker image into IBM Clouds image repo.
In the past this worked fine, and the same process still does on IBM’s hosted version of Travis. However, now the build environment when performing the curl command to pull down the install script fails with a error complaining about the SSL certificate being out of date. This also happens to when trying to pull from a different site which has a similar install script. The two sites are;
curl -sSL
curl -sSL
Both with error
curl: (60) server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

Thanks, tried this solution and it did not seem to work. It reported that none of the certificates were added or removed.

Please link to a build.

Also note that Trusty is EOL so Travis can do little to prevent its progressing lack of interoperability with newer systems.

Hi Forgive me if I misunderstand you. But here is a link to one of the builds;
I am also using;
Build language: java
Build dist: xenial
Runtime kernel version: 4.15.0-1077-gcp
Distributor ID: Ubuntu
Description: Ubuntu 16.04.6 LTS
Release: 16.04
Codename: xenial

Have now fixed this issue, by moving to dist: bionic Ubuntu 18.

1 Like