Travis does nothing after SSHing into a server?

Hello,

I’m trying to use Travis to SSH into a server so it could pull some docker images and run some lines to set up a web server. The problem is however that after I SSH into that server Travis just stops. Not in a way that it gives errors, just that after the SSH it seems to just sit and do nothing. The maximum time I’ve waited has been 8 minutes where it has seemed like the Travis script just stopped and did nothing.

So my question is: Is it normal for Travis to act in such a way or is Travis not intended to be used in such a way?

Thanks in advance,

Not normal. Travis uses stock Linux software so barring the stock logic, it’s expected to act as any other Linux machine would.

I suspect that you didn’t set up public key authentication correctly (since you’ll be using random build machines as clients, you need to pass and set a specific key pair for the build’s ssh to use that your server trusts) so it’s stuck at a prompt.

Well I checked that and it’s not it. I also tried debugging and running the same commands as I did in the script and it worked out perfectly.
Also I’m using sshpass to get into the server, may that be throwing off the Travis build? (It’s not doing it when I run the commands manually.)

Can’t say anything else without seeing a build.

Imprint