"The command "pytest -s -vvv" exited with 1." error even with all test passed successfully

My Python-3.5 Travis job https://travis-ci.com/abhiTronix/vidgear/jobs/213695560#L1939 failed with “The command "pytest -s -vvv” exited with 1." and “Done. Your build exited with 1.” unknown error even all test passed without any whatsoever error or warning. I tried everything but nothing seems to work. Weirdly the Python 2.7 https://travis-ci.com/abhiTronix/vidgear/jobs/213695559 environments built successfully with the same configuration but all the python3 environments(i.e 3.5, 3.6 and 3.7) failing with the same error every time. Please help!

Here is my Travis.yml configuration file: https://github.com/abhiTronix/vidgear/blob/c86385748c216ecd5f056fbeff1c3afc330a64ec/.travis.yml

Temporary Workaround:

Downgrading to pytest-4.6.4 seems to works and all test are passing on both python 2 and 3 environments.

Better report this on the pytest’s tracker

@webknjaz, This issue is reported on pytest’s tracker and successfully resolved here: https://github.com/pytest-dev/pytest/issues/5567