PyPy v2.7 Backwards Compatible Travis Runner Failing - print(*k) - SyntaxError: invalid syntax

First off, here is a link to my almost working build. Specifically here is the failing runner.

Back on Travis-CI.org, this worked great (but that was 5 months ago). My free credits on the new .com (per the transition) ran out and it took a really long time to get the very welcoming credits (for owning an open source project). I’m so appreciative of being acknowledged recently and granted service again. But… 5 months without any service brought with it changes i wasn’t ready for (and the CI was broken for me at the start).

I fixed most of them thanks to this ticket here allowing the Python 3.6 and Python 2.7 runners to work smoothly. However the pypy2.7-6.0 still does not :slightly_frowning_face: .

The error is:

tox
GLOB sdist-make: /home/travis/build/caronc/apprise/setup.py
....
  File "/home/travis/virtualenv/pypy2.7-6.0.0/site-packages/setuptools/sandbox.py", line 45, in _execfile

    exec(code, globals, locals)

  File "/tmp/easy_install-XU9z6B/pytest-runner-5.3.0/temp/easy_install-9oP4zp/setuptools_scm-6.0.1/setup.py", line 52, in <module>

  File "/tmp/easy_install-XU9z6B/pytest-runner-5.3.0/temp/easy_install-9oP4zp/setuptools_scm-6.0.1/setup.py", line 29, in scm_config

  File "/tmp/easy_install-XU9z6B/pytest-runner-5.3.0/temp/easy_install-9oP4zp/setuptools_scm-6.0.1/src/setuptools_scm/__init__.py", line 8, in <module>

  File "/tmp/easy_install-XU9z6B/pytest-runner-5.3.0/temp/easy_install-9oP4zp/setuptools_scm-6.0.1/src/setuptools_scm/config.py", line 6, in <module>

  File "/tmp/easy_install-XU9z6B/pytest-runner-5.3.0/temp/easy_install-9oP4zp/setuptools_scm-6.0.1/src/setuptools_scm/utils.py", line 41

    print(*k)

          ^
SyntaxError: invalid syntax

Previously I had an entry in the .travis.cfg file that read:

pip install .

When that was in place, then the exact same print(*k) SyntaxError would happen there instead (source).

Any help/advice would be most welcome! :slight_smile:

tests_require in setuptools is broken and deprecated. Don’t use it in your setup.py.
It installs dependencies in an obsolete way that did not work in this case.

Thank you for your prompt reply but unfortunately didn’t help :slightly_frowning_face: . Even after removing the entry, it still fails in the same spot with the same error (source).

Edit: I apologize, i see that i missed reference to pytest-runner which i was able to find from the link you shared that resided in setup_requires. That in addition to your advice appeared to fix it! Thank you so much! :+1:

1 Like
Imprint