Proper support for 0.19.1?

Apologize for the cross-post between here and the elm-community/travis-ci repo on GitHub, but I figured I might reach more possible eyes through both.

Hi, I had a rough time getting Elm language support to run on travis for Elm 0.19.1. I tried setting the elm version in the .travis.yml to:

language: elm
elm: 0.19.1-3

However, this would cause the script to search for a matching elm-test, which doesn’t follow the same numbering scheme apparently. So I tried setting both it and elm-format's version:

language: elm
elm: 0.19.1-3
elm-test: 0.19.1
elm-format: 0.8.2

However, it seems that there is a bug where you cannot override these independent of the elm version (see Cannot override elm-test version).

So, as a workaround, I removed the aforementioned versions, and added an install block to my .travis.yml:

language: elm

install:
  - npm install -g elm@0.19.1-3
  - npm install -g elm-test@0.19.1
  - npm install -g elm-format@0.8.2

This is a little inefficient, since it installs the defaults first, followed by these ones, but it does the trick for now. Any chance this will be fixed? This package seems pretty dead in the water judging by the travis-ci community page.

What exactly are you expecting as “proper support”? Somehow guess which elm-test version you need even when it’s different form elm version?

You can write a pull request to fix the bug that you referred to (or e.g. have someone do that for you), then your second snippet should work.

Imprint