NOT_CRAN changes on Travis for the R build

I have the problem of testing my builds as if it was a CRAN build. See the following Travis log:
https://travis-ci.org/rOpenGov/pxweb/jobs/468619067

I set the NOT_CRAN to “false” in the travis.yml file and this seem to work (see row 889 in the log file), but during the testing of the package this is changed to “true”, see row 1182.

Maybe it would be possible to include how to test packages as CRAN on travis R documentation page, since I guess I’m not the only one with this interest. =)

@jeroen and @jimhester

The issue is the variable is set in the export step, which seems to be run after user defined variables are set. Explicitly setting the variable in the before_script stage should work.

before_script: export NOT_CRAN=false

Thank you! It worked.

Maybe make this more clear in the R documentation for Travis? Now it is said to set env variables from Travis. Or is it a bug in devtools? Seems strange no one have had this problem before.

You can suggest improvements to documentation by following the “Improve this page on Github” link on top of a documentation page.

Imprint