Not Able to Deploy to my Github

Hi, this is my first time posting here but I have been trying to deploy a Linux release to my Github but it keeps failing for authorization errors. I have tried using both a api key and my username and password in the yml file. Was wondering if you guys can take a look. Thanks for any help you can give.

Here is the error:

travis_fold:end:dpl.1
travis_fold:start:dpl.2
e[33mPreparing deploye[0m

travis_fold:end:dpl.2
/home/travis/.rvm/gems/ruby-2.4.5/gems/octokit-4.6.2/lib/octokit/client/authorizations.rb:125:in `scopes': Access token required (ArgumentError)
	from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-releases-1.10.15/lib/dpl/provider/releases.rb:89:in `check_auth'
	from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.15/lib/dpl/provider.rb:187:in `block in deploy'
	from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.15/lib/dpl/cli.rb:41:in `fold'
	from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.15/lib/dpl/provider.rb:186:in `deploy'
	from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.15/lib/dpl/cli.rb:32:in `run'
	from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.15/lib/dpl/cli.rb:7:in `run'
	from /home/travis/.rvm/gems/ruby-2.4.5/gems/dpl-1.10.15/bin/dpl:5:in `<top (required)>'
	from /home/travis/.rvm/gems/ruby-2.4.5/bin/dpl:23:in `load'
	from /home/travis/.rvm/gems/ruby-2.4.5/bin/dpl:23:in `<main>'
failed to deploy

Here is my yml file:

language: cpp

git:
  depth: 1
  
sudo: required
dist: xenial

install:
    - bash ci-scripts/$TRAVIS_OS_NAME/travis-install.sh
script:
    - bash ci-scripts/$TRAVIS_OS_NAME/travis-build.sh

matrix:
    include:
        - os: linux
          compiler: gcc
          cache: ccache
        - os: linux
          compiler: clang
        - os: osx
          osx_image: xcode10.1

 deploy:
  provider: releases
  user: "DoctorRyan"
  password: "xxxxxxxxxxxxxx"
  file: "Release.zip"
  skip_cleanup: true
  on:
    tags: true

Hello, there.

First of all, I’d like to urge you to not use the password in plain text, especially when it can be accessed publicly.

Second, I’m guessing that the API client cannot use the username/password combo if 2FA is enabled (because we cannot pass the token to the client when it is used.

I highly urge you to:

  1. Change the password if you haven’t done so already
  2. Use (encrypted) OAuth token to deploy.

I will change my password. Thanks. I am kinda new at some of this. Actually I also tried to do a Oauth token as well and still had issues. However I did not encrypt it though. I may try that to see if it makes a difference.

Imprint