"mv: rename cacert.pem to /etc/ssl/cert.pem: No such file or directory"

My OSX build fails when cloning the git repo:

$ git clone --depth=50 --branch=1.0-SNAPSHOT https://github.com/ogerardin/xpman.git ogerardin/xpman
Cloning into 'ogerardin/xpman'...
fatal: unable to access 'https://github.com/ogerardin/xpman.git/': error setting certificate verify locations:
  CAfile: /etc/ssl/cert.pem
  CApath: none

I suspect this is caused by a previous error:

mv: rename cacert.pem to /etc/ssl/cert.pem: No such file or directory

This project used to build reliably, the previous build was 3 months ago. The Travis config didn’t change.
This is purely OSX related, as the same project builds successfully on Windows and Linux.

Failed build: job 552855009
Previous successful build: job 536671303

Thanks for your help.

Could you try removing the git depth? See if that affects the error frequency.

I don’t see how it could be possibly related but I tried anyway, it didn’t change anything: job 553060820

PS: the error frequency is 100%

We are working on a certificate issue for the Xcode9.3 version. Until then using the recent version of Xcode i.e. osx_image: xcode12.5 should be helpful.

Thanks.

1 Like

Thanks for the heads up!
Unfortunately I need JDK 8 and xcode9.3 is the latest image to support JDK8. Unless there is some workaround?

This should be a bit helpful, but AFAIK there’s no workaround, I’ll look into it a bit further.

This should be a bit helpful, but AFAIK there’s no workaround, I’ll look into it a bit further.

I can’t do much on my side, the build was working perfectly before… Unless you know of a way to install Oracle JDK8 in any of the subsequent macOS images that don’t come with it?

Hey @ogerardin,

Using osx_image: xcode9.4 should provide JDK8 and resolve the certificate issue.

Thanks,

Hi @mustafa

Using osx_image: xcode9.4 should provide JDK8 and resolve the certificate issue.

Did that change recently? The macOS doc page still says:

if your Mac build requires Java 8 and below, use xcode9.3 (or below); if your build requires Java 10 and later, use xcode9.4 (or later).

Thanks @ogerardin for the heads up. We will be updating the docs as well.

Imprint