Msbuild timeout

Hello guys!

I am facing some weird problems here. When I try to build with mingw everything works fine because it outputs everything.

But if I try to do the same with msbuild.exe, I receive timeout because it doesn’t output anything. I guess it is caused by msbuild.exe running its jobs in a separated shell.

$ cd build && msbuild.exe Engine.sln

No output has been received in the last 10m0s, this potentially indicates a stalled build or something wrong with the build itself.

Check the details on how to adjust your build configuration on:

The build has been terminated

BTW I tried running with cmake --build and the problem persists.

How can I make msbuild.exe work and avoid termination by timeout, and more importantly, how can I get the output going?

Is it possible to use powershell as default and get all the logs?

Thanks in advance!

Hi there!

Take a look to this work-around:

Whether you may apply it or not depends on whether you have deployment secrets or not.

I have not tried to set the secrets_filter to true AFTER executing msbuild, it may or may not help those setups needing badly secrets for deployment.

Much luck,