Missing libraries for Ruby 2.1, 2.2, and 2.3 on macOS

When building on macOS using Ruby 2.1, 2.2, or 2.3, the OpenSSL libraries are missing.

Libraries missing for ruby-2.1.10: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib,/usr/local/opt/openssl/lib/libssl.1.0.0.dylib. Refer to your system manual for installing libraries

There are some similar reports, but for different libraries and different Ruby versions.

All of the failing jobs in this build are failing with this error.

1 Like

Crikey, this is another manifestation of

1 Like
Imprint