Homebrew requires Ruby 2.6, Travis provides 2.3.3

Hi,

For several weeks, we’ve been getting error messages like this when we try to use any brew commands inside of our macOS build:

Homebrew must be run under Ruby 2.6! You’re running 2.3.3

Example build: https://travis-ci.org/terralang/terra/jobs/624807937

This seems to make it impossible to actually use Homebrew from inside of Travis. Is there a workaround or can this be fixed?

1 Like
Imprint