Default python version in non python environments

Hello,
I’m trying to run a small python step ina after_script step in a node_js build, the issue is that I’m getting SSL issues due to old python version (2.7.6) which is extremely old.
There is a specific reason for this old python? how can I bypass this issue?
The build is for node_js package, the script I want to run after written in python.

Thanks,
Moshe

The default versions are those provided by distro. See Python 3.6 and 3.7 with system_site_packages enabled fails to activate on xenial .

If your language: is not python, Travis logic to install Python is not available and you have to install it yourself, see Installing python >=3.6 in a cpp image .

Imprint