Can we upgrade Node.js in the Dart environment to 8.0+

It looks like some builds are breaking because:

Firebase CLI v7.0.1 is incompatible with Node.js v6.12.0 Please upgrade Node.js to version >= 8.0.0

This is Firebase CLI (in this case, used to deploy a Firebase Hosting project), but I expect other NPM packages will start expecting higher versions of Node.js than 6.12 soon. Current Node.js LTS is 10.16.0, with end of life in 2021. Node.js 6 LTS maintenance period has ended this year.

cc @nex3 & @a14n

1 Like

Please include relevant build URLs when you report a problem. Thanks.

Hi, sorry for the late reply, I missed the notification for this.

By now, node is on version 10+ (and firebase-tools expects that) but the dart Travis environment seems to be at v8.12.0.

nvm is available to manage Node.js versions: nvm install 12 (or whatever version you need). The installation should be short and has minimal impact on your build time.

1 Like

Thank you! This worked!