Bioconductor version error

@jeroen, @jimhester
Hi,
I am the maintainer of this scMerge package for Bioconductor. The issue that I am having is that Travis seems to be using Bioconductor version 3.8 rather than the newly released 3.9 (https://travis-ci.org/SydneyBioX/scMerge/jobs/529095216). This caused an installation error for a dependent BioC package M3Drop (scMerge requires M3Drop version >= 1.9.4).

I am unsure if this is a bug or not.

Thanks

1 Like

Looking through the code that generates download URLs suggests that “3.8” comes from the R_BIOC_VERSION envvar.

According to https://bioconductor.org/install/, you can install the latest Bioconductor version with

if (!requireNamespace("BiocManager", quietly = TRUE))
    install.packages("BiocManager")
BiocManager::install()

Maybe it’s sufficient to set the envvar: the logic suggests that it may be calling the above code in any case.

I am being hit by this too for a package of mine: https://travis-ci.org/xrobin/xavamess/jobs/535684539

Did you manage to solve the issue?
I don’t set the R_BIOC_VERSION variable anywhere, nor do I install or load BiocManager anywhere… I assume that’s done in a setup script?

I managed to get around this problem by writing up a short R script in the travis.yml file. But I think this is only a short-term patch. https://travis-ci.org/SydneyBioX/scMerge/builds/534666350/config

@LiNk-NY has stated that this was an upstream problem – they had an issue updating the BiocManager package at CRAN.

So this should be working now without any workarounds. You may need to clear your cache.

@native-api it’s working now, thanks a lot!
By the way I didn’t have to clean the cache - however I had done it previously, so not sure about it.