All builds stuck in "Job Received"

Hello,
Suddenly on Friday August 20th Travis stopped processing any new build jobs. Travis just spins on “Job Received”
I have a ticket open on the issue, but I have only received replies that they are working on it, but nothing else.
This is a paid account running on private repos
In case someone has privileges with Travis this is an example
https://app.travis-ci.com/github/hwtears/lwt-core/jobs/532928569
I have 20-30 repos that build in travis. Any I have tried to do the same thing including repos that have not been touched in months.
I have repeatedly canceled jobs to clear out the queue
I have uninstalled the Travis integration from Github and reinstalled it
I have set up a new vanilla repo
I have tried alternate architectures and environments in Travis to see if the problem was isolated to certain build resources
Still, all of the builds get stuck on “Job Received”. I had one random one go through in the middle of the night on Sunday morning, but subsequent jobs on the same and all other repos have resulted in the same thing.
I contacted the Twitter account and they suggested I post here.

Please note that Travis CI does not receive a Webhook event when more than three commits are tagged. So if you do git push --tags , and more than three tags that are present locally, are not known on GitHub, Travis will not be told about any of those events, and the tagged commits will not be built.

My guess is you have (or had) a lot of jobs in queue, given this quote:

Looking into this further, but it seemed the problem started when somebody switched branches, I’ll keep you posted here in the interim - let me look into this further.

Thank you for looking into this.
Any type of commit on any of our repos will recreate this issue. Even test commits where I make a trivial change to a file to trigger a build results in the same issue
Yes, we have had our queue get quite large at times, but I have been canceling them only keeping the latest commits on each repo.
Do you mean someone switching branches on one repo broke all the builds on our account?

To the last question, just an observation I made, which is when the issue started when the build was started on a different branch, I’m not going to name branches here on a public forum, but I’ll be actively looking into this and get you a solution as soon as possible.

2 Likes

I forgot to say my trouble tickets are 31800 and 31737. The latter from Friday may be now merged with the former.

Thanks,

Ah, okay that makes more sense now!

1 Like

Would additional links to builds that are queued be helpful?

https://app.travis-ci.com/github/hwtears/hwt-educator-backend/jobs/533538629
https://app.travis-ci.com/github/hwtears/letter-number-formations/jobs/533540033
https://app.travis-ci.com/github/hwtears/mat-man-educator-frontend/jobs/533516285
https://app.travis-ci.com/github/hwtears/automation-prekitt/jobs/533472408

Hey @hwtearsdigi,

Okay so I went ahead and canceled all your builds that were in queue, try and rebuild and see if you have any luck!

1 Like

I restarted a previously queued job and started a new one based on a new commit and still the same. It is spinning at “Job Received”

Okay, I’ve reset them again - this time a bit more of a manual way. If this doesn’t work I will talk to some support staff and get to the bottom of it as quickly as possible.

This job ran successfully 26 minutes ago. This was one I left running I believe
https://app.travis-ci.com/github/hwtears/lwt-core/builds/235881628
I tried restarting another job and its stuck spinning:
https://app.travis-ci.com/github/hwtears/mat-man-educator-frontend/jobs/533537597
I did a trivial change to another repo to trigger a new build and its spinning
https://app.travis-ci.com/github/hwtears/PrintToolOnline/jobs/533586454

Okay interesting, that’s when I about cancelled all the jobs the 1st time, let’s give it an hour and see if the ones in queue finally build - there’s a few other things I can do to diagnose the problem.

1 Like

Looks like they are still queued

This one started going and completed without any changes on my end
https://app.travis-ci.com/github/hwtears/mat-man-educator-frontend/builds/236118081

It seems like jobs are going through now. The only update I received from support was that they were working on it. I’ll let you know if anything changes.

1 Like

Okay, this seems to be working after I manually reset all the jobs on our backend side. Please let me know if you have anymore issues and I’ll be glad to help you, seems like even the repos with cron enabled are now building without a hitch.

Montana Mendy
Travis CI Staff

1 Like
Imprint