Dotnet core 2.2

Can you post your yaml-code?
Yes, you need to define mono: none otherwise it will install mono.

I am working with dist: bionic and dotnet: 2.2.105. Works perfectly for me!

I need to do this with Windows, so can’t use the linux dist’s. Do we know when 2.2. will be supported in Windows with Travis?

1 Like

Any update on 2.2 on Windows? It feels a little overdue now, given that 2.2 was first released in December 2018.

This doesn’t work even with xenial or bionic in my case. This is my travis file:

dist: xenial
language: csharp
mono: none
sudo: required
dotnet: 2.2

As I said I also tried bionic. I also tried other dotnet versions like 2.2.0, 3.0. Nothing worked. Always the same error.

$ export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=1
$ export DOTNET_CLI_TELEMETRY_OPTOUT=1
E: Unable to locate package dotnet-sdk-2.2
E: Couldn’t find any package by glob ‘dotnet-sdk-2.2’
E: Couldn’t find any package by regex ‘dotnet-sdk-2.2’
The command “sudo apt-get install -qq dotnet-sdk-2.2” failed and exited with 100 during .

Can anybody help?

5 Likes

We’re having the same issue currently, setting the dist to xenial/bionic doesn’t make any difference. Also tried other dotnet versions, but no luck. :frowning:

Same problem for us. Any clue what happened? It was working yesterday for the same project.

I surrender using the default Travis dotnet support.
Using Snap is working fine https://github.com/NosCoreIO/NosCore/blob/master/.travis.yml this is an exemple with dotnet core 3.1

kindly ask , how to solve this problem at last?

Imprint