Travis ci env set using travis ci cli(encrypt-file) are not showing up in the travis ci web UI

All the env variables set using travis cli are not showing in the setting page of my project. I am encrypting a file and I want the key and iv env variables to get into the project env variables. The variables show up when I run the command “travis env list” but doesn’t show up in the project settings in the travis ci web ui

I tried

  1. Removing the github project and including it back again into travis ci
  2. Renaming the github project
  3. Clone the project again on my local machine.
  4. Cleared the environment variables and re-ran encrypt-file command

what ever I do the environment variables don’t show up in travis ci

Environment variables set in the webui don’t show up when I run the travis env list command on my local machine

Most probably, you are using different sites – travis-ci.org vs travis-ci.com – in Travis Cli and Web UI.

You need to log in to an appropriate site with Travis Cli with travis login --org or travis login --com.

It looks like I have account in the both the sites. I revoked the permissions for travis-pro from github, but I still don’t see the env getting synced from travis cli to travis-ci.org. I used --org for every command that I have executed.

Please link to an affected build and show an MCVE of what you are doing in the console. So that I can see what exactly you are doing, what you are getting and what you are expecting to be different.

Imprint