# Redis-server.service somehow not found

**URL:** <https://travis-ci.community/t/redis-server-service-somehow-not-found/13653>\
**Category:** Travis CI Discussions & Feedback\
**Tags:** bug\
**Created:** [March 1, 2023, 7:19am UTC](https://travis-ci.community/t/redis-server-service-somehow-not-found/13653 "2023-03-01T07:19:17Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![dirtside](https://sea1.discourse-cdn.com/flex015/user_avatar/travis-ci.community/dirtside/32/7666_2.png) [@dirtside](https://travis-ci.community/u/dirtside)\
**Post date:** [March 1, 2023, 7:19am UTC](https://travis-ci.community/t/redis-server-service-somehow-not-found/13653/1 "2023-03-01T07:19:17Z")

</div>

So we’re upgrading to PHP 8.2, and after wrasslin’ with Travis for a bit, we mostly got it to work, except that apparently the redis-server service isn’t starting. This message shows up in our logs:

```auto
$ sudo systemctl start redis-server
Failed to start redis-server.service: Unit redis-server.service not found.

```

Job link: [Travis CI - Test and Deploy with Confidence](https://app.travis-ci.com/github/zamnetwork/wowhead/jobs/597016669) The error is on line 163 of that log.

Any help would be appreciated. Thanks!
