# PRs started failing on 6/12

**URL:** https://travis-ci.community/t/prs-started-failing-on-6-12/3707
**Category:** PHP
**Created:** [June 13, 2019, 4:11pm UTC](https://travis-ci.community/t/prs-started-failing-on-6-12/3707 "2019-06-13T16:11:37Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![jarednova](https://sea1.discourse-cdn.com/flex015/user_avatar/travis-ci.community/jarednova/32/1960_2.png) [@jarednova](https://travis-ci.community/u/jarednova)
#### Post date: [June 13, 2019, 4:11pm UTC](https://travis-ci.community/t/prs-started-failing-on-6-12/3707/1 "2019-06-13T16:11:37Z")

</div>

Hello!

I run the [Timber](https://github.com/timber/timber) project and we use Travis heavily to validate our PRs, etc. Yesterday starting at around 1pm Eastern US Time (June 12, 2019). All of the new PR builds started to fail, some examples:

> <https://github.com/timber/timber/pull/2027>

  
[https://travis-ci.org/timber/timber/builds/544916379](https://travis-ci.org/timber/timber/builds/544916379)

> <https://github.com/timber/timber/pull/2025>

  
[https://travis-ci.org/timber/timber/builds/544886496](https://travis-ci.org/timber/timber/builds/544886496)

Nothing in these PRs changed Travis or other setup scripts. What’s very strange is that the current master still builds properly (when I re-run one of these builds):

[https://travis-ci.org/timber/timber/builds/539249629](https://travis-ci.org/timber/timber/builds/539249629)

Even stranger, OLD PRs (submitted before 6/12) build successfully when I re-run tests:

> <https://github.com/timber/timber/pull/2013>

  
[https://travis-ci.org/timber/timber/builds/544238623?utm\_source=github\_status&utm\_medium=notification](https://travis-ci.org/timber/timber/builds/544238623?utm_source=github_status&utm_medium=notification)

I thought: there must be a change to the Travis or test scripts that I’m just not seeing. So I branched master and made as superficial change to the readme. The result? Failing test:

> <https://github.com/timber/timber/pull/2029>

  
[https://travis-ci.org/timber/timber/builds/545324749](https://travis-ci.org/timber/timber/builds/545324749)

This tells me it’s nothing with the repo’s scripts or code. But something in the config, GitHub or Travis execution.

Has anyone encountered anything similar? Does anyone from Travis have any ideas?

---

<div class="post-metadata">

### Author: ![jarednova](https://sea1.discourse-cdn.com/flex015/user_avatar/travis-ci.community/jarednova/32/1960_2.png) [@jarednova](https://travis-ci.community/u/jarednova)
#### Post date: [June 13, 2019, 4:28pm UTC](https://travis-ci.community/t/prs-started-failing-on-6-12/3707/2 "2019-06-13T16:28:45Z")

</div>

Solved! It looks like Travis changed the default dist from trusty to xenial. Not sure why, but it seems Xenial (Ubuntu 16.04) doesn’t have the right perms for MySQL. Specifying Trusty did the trick!

[https://docs.travis-ci.com/user/reference/overview/](https://docs.travis-ci.com/user/reference/overview/)

---

<div class="post-metadata">

### Author: ![native-api](https://sea1.discourse-cdn.com/flex015/user_avatar/travis-ci.community/native-api/32/430_2.png) [@native-api](https://travis-ci.community/u/native-api)
#### Post date: [June 13, 2019, 8:07pm UTC](https://travis-ci.community/t/prs-started-failing-on-6-12/3707/3 "2019-06-13T20:07:51Z")

</div>

I don’t see [`services: mysql`](https://docs.travis-ci.com/user/database-setup/#mysql) in [your config](https://travis-ci.org/timber/timber/jobs/544916380/config).

---

<div class="post-metadata">

### Author: ![BanzaiMan](https://sea1.discourse-cdn.com/flex015/user_avatar/travis-ci.community/banzaiman/32/67_2.png) [@BanzaiMan](https://travis-ci.community/u/BanzaiMan)
#### Post date: [June 13, 2019, 8:42pm UTC](https://travis-ci.community/t/prs-started-failing-on-6-12/3707/4 "2019-06-13T20:42:04Z")

</div>

> **[The Travis CI Blog: Ubuntu Xenial 16.04 as the default Travis CI build...](https://blog.travis-ci.com/2019-04-15-xenial-default-build-environment#1-services-support)**
>
> Xenial as the default Travis CI build environment is coming up next week, starting incrementally on Tuesday April 23rd, 2019.
> 
> Since Ubuntu 14.04 reaches End of Life on April 30th, 2019, we’ll be g...

We don’t start MySQL by default now on Xenial. You need to explicitly specify it.

---

<div class="post-metadata">

### Author: ![jarednova](https://sea1.discourse-cdn.com/flex015/user_avatar/travis-ci.community/jarednova/32/1960_2.png) [@jarednova](https://travis-ci.community/u/jarednova)
#### Post date: [June 14, 2019, 12:01am UTC](https://travis-ci.community/t/prs-started-failing-on-6-12/3707/5 "2019-06-14T00:01:05Z")

</div>

Thanks so much @native-api and @BanzaiMan! I’ll specify Xenial and MySQL — really appreciate the (quick) answers!
