Ppc64le: An error occurred while generating the build script

There are no clear messages, I have no idea what I’m doing wrong. Thanks a lot for Travis!



Bottom line: the contents of env: global: must be a list:

  - secure: "<etc>"

If you enable build config validation, it might detect and/or fix this automatically.

Running travis-build (the component responsible for generating a build script from .travis.yml) locally as explained in https://github.com/travis-ci/travis-build/blob/master/README.md shows the exception:

E Travis::Build::EnvVarDefinitionError: Environment variables definition is incorrect.
/home/vmuser/travis-build/lib/travis/build/env/var.rb:30:in `rescue in parse'
/home/vmuser/travis-build/lib/travis/build/env/var.rb:23:in `parse'
/home/vmuser/travis-build/lib/travis/build/env/config.rb:20:in `block in env_vars'
/home/vmuser/travis-build/lib/travis/build/env/config.rb:20:in `each'

I had to patch the appropriate source line to include the offending line in message. Which turned out to be

[:secure, "B3manbbi0anCAGDJTdAa9TlodzRHeiYD87FKmFzS877dPm8Cm0BDvtUhKBUpBvP8+nbHOWFGrgDmLugSZjTGU+mAxtuQpamUFHvinu0BIk3qtjlqouwvbtIqUu8iiZ3Uqu+xKeAANKRy0YVZGLlEb9F3N119tJ/Fxp1p9bXL1qph+CZ25OFbUgZ2s4F+/AyHMUxJlNXKFe3Qean65hC6edhU3zoaKzr/g/wtbhRmcyWbkOa1dJqzr2yKotcPvrnApGhDzgMKFtohg/t7xfMADDVv6sGS5XNpt25Z+MUCmLg4Z9eD7u109jvRV1eu/jgVafqsthWEhXbuMiFgFhKBKGCNZ0dACIfKZSkFZI6FdM7ovJ6aNhSlxZ2169Ybd22rN1UTHeCQWySPcVVOg5taLVpqe+E8Xhnv4hBO5NrzElWwCMLxIdPUSwVStYvtDr8ZytHWzfot50vSnFKIFpTOr9hP4+AJMVmmqJfaJo2MLBft/q2xkztrMv3lQSj3m4+ma9kPDwXIu9uCutjlnhc00jNx9qegi5VfpAjxcG1R+pX4T20az6ByHk/7LPQsANkT31RJq/jAeD9LEuMOy8miha83q4QuvbFaqPK3PY0el/O1LZaXqLsV2aQ0uqH8YX0l4r5NzHdhb+3lYgvpMBO5ytr/EWJiEyNYV518050IUDE="]

I also experienced this issue: ppc64le started occasionally fail with An error occurred while generating the build script., for no obvious reason after some time working without problems.
It looks like to be a travis issue.



Hi Pevik,

Thanks for your message. Yes, I don’t think native-api’s answer is the full story: I’ve had this definition of my secure variable for ages, and it always worked (meaning: the value was taken into account). And as could be seen in that build, it worked on the other architectures.

Yet, for some reason, it worked once on PPC64le (https://travis-ci.org/akimd/bison/jobs/628598485?utm_medium=notification&utm_source=email) without native-api’s fix for the secure var, and failed again since then (https://travis-ci.org/akimd/bison/jobs/628606198?utm_medium=notification&utm_source=email) with no clear error message, although I did add “version: ~> 1.0”. That’s with native-api’s fix for the syntax for the secure var. Finally, in https://travis-ci.org/akimd/bison/jobs/629406118 I completely removed the definition of the secure var, to no avail.

So I also do believe the problem is rather on Travis’ side.

FWIW though, I kinda sad: I was hoping one of these architectures would have char being unsigned, but it appears that it’s not.

Cheers! And Merry Christmas!

For @pevik’s config, travis compile runs without error, so this must the in the proprietary part of the machinery thus I cannot help here any further.

Same thing here:
all projects using ppc64le are failing currently, precisely and only on the ppc64le test, with the same message :

An error occurred while generating the build script.


Builds on ppc64le .org are back to normal.
We are sorry for the inconvenience.


@akimd - I think there was a back-end issue , please retry job deployment now , its back to working normally now - https://travis-ci.org/ghatwala/python-testing/builds/612015314

Hi Damian,
Yes, it’s back. Thanks a lot!

FTR, the syntax check for travis.yml does not know about git: clone: false. See https://travis-ci.org/akimd/bison/builds/630957210/config for instance:

Build config validation

jobs.include.git : unknown key clone ( true )
git : unknown key clone ( false )
root : missing os , using the default linux
language : value minimal is an alias for shell , using shell