MacOS build fails because of homebrew "bundle" unknown command

Oh, sorry for lacking that. I’ve just edited the post, thanks for the “clarification request”.

Confirmed on, all macOS builds have been failing for the past 5 hours with the same “bundle” issue. Builds older than 6 hours ago were working fine.

Failed build (15:02 UTC):
Working build (13:30 UTC):

Relevant matrix config:

By the way, I put brew update and then brew install ... commands into my .travis.yml now. It did the trick as a kind of workaround, it seems, however now it’s about four minutes longer to finish … I guess this is not the optimal solution after all, and also hides the problem why it does not work anymore since some hours which worked before …

Indeed, yesterday it worked fine yet, today did not … I wouldn’t have any more precise timing though when the problem occurred the first time …

Experiencing the same issue

Same here.

Short web search told me that homebrew bundle has been announced as deprecated – it seems to have vanished now. I do not use macOS personally, but offering support for it would be quite nice. Thanks in advance!

Seems like this commit:

broke the installation of that tap. In order to provide external commands (like brew bundle) Homebrew expects a file brew-bundle.rb, which has been deleted from the repo (or renamed bundle.rb

From this issue: it seems like brew update might fix the issue. Would be nice if the Travis team could update the build image, rather than requiring us to run brew update on every build. As you note in your docs:

By default, the Homebrew addon will not run brew update before installing packages. brew update can take a long time and slow down your builds.

edit: confirming that adding update: true fixes my build.

        - graphicsmagick
        update: true

Can you provide a link to the deprecation announcement? I can’t find that anywhere.

I stumbled over this SO question, which points to this issue. Just realized, however, that those links are quite dated.

Thanks a lot!

update: true

works for me as well. Takes a while, though, but at least the build runs now.

1 Like

How frequently do the macOS virtual machines receive updates?

My understanding is that Homebrew Bundle, which the Homebrew addon uses, now depends on Homebrew 2.2.5, and the macOS virtual machines currently ship an older version.

Until the virtual machines receive an update, or something else changes, the workaround is to update it via update: true, as above.


I opened a macOS Packer Templates PR to add Homebrew Bundle to the macOS images and avoid mismatches between the installed (stale) version of Homebrew and latest version of Homebrew Bundle.


They say they are thinking about it, but not very hard apparently:


I also have the same issue with many of my projects:

We have the same problem too:

Add update: true under the homebrew: key in your environment.

Thanks to @BanzaiMan. Also see OS X image and “Error: Unknown command: bundle” and MacOS build fails because of homebrew “bundle” unknown command.

@BanzaiMan Can we expect an updated macOS image in coming days to solve this? Having Homebrew updated to a current functional version directly in the image should reduce build times for all of us who currently had to resort to forcing update: true in our builds.

1 Like

The new image is available:

1 Like

Confirmed fix for OSX 10.12-10.14 (Homebrew currently supports 10.13+)
See MacOS build fails because of homebrew "bundle" unknown command.

1 Like

I think it’s a misinformed that it’s fixed for OS X 10.12-10.14, but rather Xcode of the mentioned version–only macOS 10.14 is fixed.

1 Like