How to install spatialite on Xenial?

I’m in a catch-22, dependency-wise. My test matrix includes the latest Django, 2.2, which requires sqlite3 > 3.8.2, which rules out Trusty. Updating to Xenial breaks Spatialite, as libsqlite3-mod-spatialite is the right package to use for spatialite (or so I’m told?), but it’s not whitelisted, and there’s no source alias for it.

Imprint