Fastlane build copy step hangs

We run fastlane on travis xcode10.3 instances to build our apple apps. We recently upgraded from fastlane ver 2.105.2 to 2.131.0 and now our build hangs. It seems to hang on either a copy or a generating dSYM step. We revert back to 2.105.2 and it works just fine again. It seems to only happen when running in a travis instance, I am not able to reproduce this on my own laptop (OSX Mojave). Was wondering if anybody else has run into this issue?

------------- travis.yml -----------------------

language: objective-c
osx_image: xcode10.3
xcode_workspace: mPower2.xcworkspace
xcode_scheme: mPower2
cache:
  - bundler
	  addons:
	    homebrew:
		packages: python3
before_install:
	- echo -e "machine github.com\n  login $CI_USER_TOKEN" >> ~/.netrc
	- pip3 install virtualenv
	- virtualenv -p python3 ~/venv
	- source ~/venv/bin/activate
install:
	- pip install travis-wait-improved
	- gem install bundler
	- bundle install
script:
	- travis-wait-improved --timeout 30 ./travis/build.sh
branches:
	only:
	  - master
	  - "/^stable-.*$/"

-------------------------- build log ----------------------------
https://travis-ci.org/Sage-Bionetworks/mPower-2-iOS/builds/584321831#L4224

	[20:54:47]: ▸ Processing Info.plist
	[20:54:47]: ▸ Generating 'mPower2.app.dSYM'
	[20:54:47]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/ResearchUI.framework
	[20:54:47]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/ResearchMotion.framework
	[20:54:47]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/ResearchLocation.framework
	[20:54:47]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/Research.framework
	[20:54:47]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/MotorControl.framework
	[20:54:47]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/DataTracking.framework
	[20:54:48]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/BridgeSDK.framework
	[20:54:48]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/BridgeAppUI.framework
	[20:54:48]: ▸ Copying /Users/travis/Library/Developer/Xcode/DerivedData/mPower2-gguyppdqoavrulaqjlhshlebdwgf/Build/Intermediates.noindex/ArchiveIntermediates/mPower2/BuildProductsPath/Release-iphoneos/BridgeApp.framework
	Travis-wait ❱ 0:15:59 remaining
	Travis-wait ❱ 0:14:59 remaining
	Travis-wait ❱ 0:13:59 remaining
	Travis-wait ❱ 0:12:59 remaining
	Travis-wait ❱ 0:11:59 remaining
	Travis-wait ❱ 0:10:59 remaining
	Travis-wait ❱ 0:09:59 remaining
	Travis-wait ❱ 0:08:58 remaining
	Travis-wait ❱ 0:07:58 remaining
	Travis-wait ❱ 0:06:58 remaining
	Travis-wait ❱ 0:05:58 remaining
	Travis-wait ❱ 0:04:58 remaining
	Travis-wait ❱ 0:03:58 remaining
	Travis-wait ❱ 0:02:58 remaining
	Travis-wait ❱ 0:01:58 remaining
	Travis-wait ❱ 0:00:58 remaining
	Travis-wait ❱ 0:00:10 remaining
	Travis-wait ❱ 0:00:09 remaining
	Travis-wait ❱ 0:00:08 remaining
	Travis-wait ❱ 0:00:07 remaining
	Travis-wait ❱ 0:00:06 remaining
	Travis-wait ❱ 0:00:04 remaining
	Travis-wait ❱ 0:00:03 remaining
	Travis-wait ❱ 0:00:02 remaining
	Travis-wait ❱ 0:00:01 remaining
	Travis-wait ❱ Timeout reached... killing child.
	Travis-wait ❱ Child has exited with: -9
	The command "travis-wait-improved --timeout 30 ./travis/build.sh" exited with 247.

Probably a deadlock in Fastlane or something. Without debugging/debug printing, impossible to say what’s happening.
I suggest you contact that product’s developers on this – especially since it’s a recent problem so they can narrow it down to a set of changes.

Imprint