Cannot set wal_level = logical on PostgreSQL 10

Build link: https://travis-ci.com/levkk/pg-logical-manager/builds/142506234

Hello there,

I’m testing against PostgreSQL 10 on Bionic, and I’d like to run ALTER SYSTEM SET wal_level = 'logical'; to use logical replication on the server. The command runs fine, but when restarting the server (this setting requires a restart of Postgres), it hangs for a long time and never restarts.

Thoughts?

Thank you!

Imprint