Building an R package with older R version (R 3.4)

Due to compatibility with other package, that works as intended with R3.4, I’d like to build mine with the same R version.

I’ trying to specify R3.4 as follows:

language: R
cache: packages

warnings_are_errors: false

matrix:

  • 3.4

But the build still fails:
https://travis-ci.com/symbioticMe/proBatch/builds/127349915

“3.4” should be under r:

r: 3.4

https://docs.travis-ci.com/user/languages/r/#r-versions

Imprint