Languages   Python


Topic Replies Activity
Starting 2019-04-16, the default version of Python will be 3.6

That is, if you do not specify the python value in your configuration, we will use version 3.6.x instead of 2.7.x. If you wish to stay on 2.7, please provide python: 2.7 # or 2.7.x for a desired value of x at approp…

3 April 10, 2019
About the Python category 1 November 7, 2018
The `python` command should be permanently reserved for Python 2 9 April 17, 2019
Add PyPy 7 support 5 April 17, 2019
Large pip installs exceed maximum log length 13 April 12, 2019
Non-python builds vs. the upcoming Python version update 3 April 10, 2019
Confusing PyPy versions 3 March 14, 2019
ImportError on public repo, not on private 7 March 14, 2019
Potential Archive Issue with Python 3.5 3 March 13, 2019
Cannot download pypy27-6.0 and pypy35-6.0 (archive url is 403 Forbidden) 5 March 13, 2019
Travis Python archive download is flaky 10 March 12, 2019
Python 3.8-dev, xenial -- unable to pip install psycopg2-binary 9 March 6, 2019
Pylint crash with AttributeError in Travis CI while working fine on local computer 3 February 28, 2019
Default python version in non python envirments 2 February 25, 2019
Detect Python Defaults [opinions wanted] 2 February 12, 2019
Unable to download Python 3.7 archive on Travis CI 10 February 8, 2019
Issue: pipenv check fails due to NumPy 5 February 7, 2019
CI build for Python 3.7 image failing 2 January 26, 2019
Travis-CI POST tests returns self.open(*args, **kw) error 1 January 19, 2019
[HELP NEEDED] Python3 unittest file mocking is not working 1 January 16, 2019
PyPI deploy provider not allowing deploy of .dev tag? 4 January 11, 2019
Pytest upgrade broke our tests (pytest-cov out of sync?) 3 January 9, 2019
Python 3.6 and 3.7 with system_site_packages enabled fails to activate on xenial 2 January 7, 2019
Issue :travis-ci fails for pypy code that imports numpy 1.16.0rc1 4 January 6, 2019
Using python3.7 does not work for sudo 3 January 2, 2019
PyPy 3.5 v6.0.0: inconsistent OpenSSL bindings 1 December 31, 2018
Installing python >=3.6 in a cpp image 5 December 21, 2018
Update pip to at least 18.x 2 December 19, 2018
Python 2.7 importing error (on Ubuntu 14.04) due to OpenMP run-time issue or system version incompatibility 5 December 19, 2018
TravisCI support for pipenv? 2 December 15, 2018